Skalarprodukt in Microsoft Excel ®

Skalarprodukt in Microsoft Excel ®

Skalarprodukt in Microsoft Excel® für Eilige

Gegeben:

Sie haben zwei Vektoren, hier :

Vektor 1 (2,-3,6) und Vektor 2 (8,2,-3)

Gesucht:
• das sogenannte „Skalarprodukt“, also

(2*8) + (-3*2) + (6*-3) = 16 – 6 – 18 = -8

Vorgehen in Microsoft Excel :

• Skalarprodukt durch direkte Berechnung errechnen

• Skalarproduktdurch Verweise (Bezüge) errechen

Achtung: die äußeren geschweiften Klammern werden nicht hingeschrieben, sondern:

  • =SUMME({2;-3;6}*{8;2;-3}) bzw.
  • =SUMME((B3:D3)*(B7:D7))
  • wird ohne Enter hingeschrieben und dann mit gleichzeitiger Betätigung der Tasten „Strg“ + „Umschalt“ + „Enter“ abgeschlossen. Dadurch werden die äußeren geschweiften Klammern erzeugt und das Skalarprodukt berechnet dargestellt.

Keine Zeit, das alles zu verstehen? Gerne können Sie mich beauftragen, um Ihr Problem in Microsoft Excel ® zu lösen.

Skalarprodukt in Excel berechnen studeto

Skalarprodukt in Microsoft Excel® am Beispiel der Ermittlung der Summe aller Umsätze

Sie haben eine lange Tabelle mit Mengen und Preisen und wollen daraus den möglichen Gesamt-Umsatz berechnen.

Mathematisch gesehen:
• errechnen Sie das sogenannte „Skalarprodukt“.

Praktisch gesehen
• wollen Sie den „potentiellen Umsatz“ berechnen.

Excel-technisch gesehen

•werden dazu „Matrizenfunktionen“ eingesetzt.

Schauen wir uns die einzelnen Schritte dazu anhand eines einfachen Beispiels an.

Die zugrunde liegende Mathematik (des Skalarprodukts) kurz in einem Schaubild zusammengefaßt:

Skalarprodukt mathematische Definition

Übertragen wir diese trockene Definition nach Microsoft Excel®, so ergibt sich ein bekanntes Bild mit Vektoren, die aus Komponenten bestehen. Diese einzelnen Komponenten (u1, v1, u2, v2, …) werden einzeln miteinander multipliziert (u1*v1 bzw. u2*v2).

Die entstehenden Produkte werden abschließend aufsummiert (u1*v1 + u2*v2) und man erhält das fertige Skalarprodukt.

Skalarprodukt in Microsoft Excel mit Mathematik-Bezug

Ersetzen wir nun die Begriffe durch ein praktisches Beispiel, so füllen sich die mathematischen Begriffe mit Zahlen aus der realen Welt. Der Vektor u steht für „Mengen“, der Vektor v steht für „Preise“. Der mögliche Umsatz berechnet sich aus Menge * Preis (oder eben aus Vektor u * Vektor v) und zwar für jede Komponente der Vektoren. Damit erhalten wir später das Skalarprodukt in Microsoft Excel.

Skalarprodukt in der Praxis

Bleibt noch die Übertragung des realen Beispiels in die Microsoft Excel® Welt. Das sieht auf den ersten Blick einfach aus, doch an einer Stelle gibt es eine Besonderheit.

Die Berechnung des Skalarprodukte (in gelb) geschieht durch eine besondere Tastenkombination. Es wird nicht nur „Enter“ betätigt, sondern gleichzeitig die Kombination aus „Strg“, „Umschalt“ und „Enter“ betätigt.

Damit werden in Microsoft Excel® die so genannten Matrizenfunktionen ausgelöst, und das Skalarpodukt in Microsoft Excel ist eben eine dieser Funktionen.

Schauen wir uns noch die notwendigen Arbeitsschritte in Microsoft Excel® an:

Skalarprodukt in Microsoft Excel - Formeln

In Microsoft Excel® können die einzelnen Vektoren (lange Spalten mit Zahlen) zur Vereinfachung einen Namen erhalten, in unserem Beispiel den Namen „Vektor_u“ oder daneben den Namen „Vektor_v“.

Dann geschieht die Berechnung, wie weiter oben beim Skalarprodukt beschieben durch:

Multplikation in der Form „Vektor_u * Vektor_v“ und oben drauf noch die Summenbildung all dieser Produkte, in Microsoft Excel also:

=Summe(Vektor_u * Vektor_v).

Aber, durch Betätigen der Tasten Strg und gleichzeitiger Drücken der Enter-Taste wird Excel angezeigt, daß wir eine Matrizenfunktion haben wollen, die über alle Komponenten die Summe bildet. Anschließend sieht deshalb die Formel so aus:

={Summe(Vektor_u * Vektor_v)}, obwohl wir selbst keine geschweiften Klammern eingeben durften, die fügt Excel hinzu und zeigt damit an, daß eine komponentenweise Multiplikation innerhalb einer Matrizenfunktion angewendet wird.

Skalarprodukt in Microsoft-Excel - Vorgehen in Schritten

Alles klar? Wenn nicht, so dürfen Sie mich gerne beauftragen und ihr Problem an mich geben.

Studeto.de

ist ein Projekt der

Gerd Gorski GG Management Dienstleistungen

© Copyright 2015-2019 by Gerd Gorski

Kontaktdaten

office at studeto.de

tel:0151 2010 8685

Microsoft Excel® Dienstleister